August 30, 2015 Login  


Clicking Look keo 2max pedals
Last Post 08/15/2014 04:51 PM by ed custer. 2 Replies.
Printer Friendly
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
zootracer

Posts:461

--
08/15/2014 12:02 PM
Brand new 2 max pedals. Starting clicking from day one. Only can hear it when climbing. I know its the pedals as I put my old Shimano 105's back on and no clicking. I tried using different cleats, regular no grip cleats and grip cleats. I lubed the springs and was quite for awhile then the clicking returned. I read that it could be the bearings might be dry, but I have no clue how to disassemble these pedals. Has anyone else had this problem and how did you fix it? Not using them anymore, brand new. I have some old Look Keo Classic pedals and never had this problem.
Keith Richards

Posts:773

--
08/15/2014 01:08 PM


See that plastic knurled washer where the spindle meets the pedal body? That unscrews and allows the spindle/bearing assembly to be extracted. You need a special tool if you don't want to round off the splines. Good luck!
----- It is his word versus ours. We like our word. We like where we stand and we like our credibility."--Lance Armstrong.
zootracer

Posts:461

--
08/15/2014 04:51 PM
thanks, I'll try that, worth a shot...
You are not authorized to post a reply.

Active Forums 4.1
NOT LICENSED FOR PRODUCTION USE
www.activemodules.com

Latest Forum Posts
Thorn season posted in The Coffee Shop

Litespeed/Campy porn posted in Gear Advice

Moto Crashes..... posted in Professional Racing

Wow! Breakthrough ride today posted in Road Cycling

Great stage today! posted in Professional Racing

Cross camp posted in Training Talk

A general service announcement posted in Professional Racing

No articles match criteria.
  Terms and Conditions | Privacy Policy  Copyright 2008-2013 by VeloNation LLC